python从就旧版本升级到3.8版本

这篇具有很好参考价值的文章主要介绍了python从就旧版本升级到3.8版本。希望对大家有所帮助。如果存在错误或未考虑完全的地方,请大家不吝赐教,您也可以点击"举报违法"按钮提交疑问。

用yum或者其它包管理器安装的py太旧了,大概是3.6版本,新版本官网上没有编译好的。现在把编译步骤记录下来方便以后使用。
1.下载
wget https://www.python.org/ftp/python/3.8.18/Python-3.8.18.tgz, tar -xvf Python-3.8.18.tgz
2.编译
cd Python-3.8.18
./configure --prefix=/usr/local/python3.8.18
make && make install
3.更新新的python链接
3.8需要kafka-python升级,python学习,python,开发语言3.8需要kafka-python升级,python学习,python,开发语言
ln -s /usr/local/python3.8.18/bin/python3.8 /usr/bin/python3
报错了,ls -ltr /usr/bin/python3
lrwxrwxrwx 1 root root 9 Oct 26 15:25 /usr/bin/python3 -> python3.6
所以先要sudo rm /usr/bin/python3,然后
ln -s /usr/local/python3.8.18/bin/python3.8 /usr/bin/python3
sudo rm /usr/bin/pip3
ln -s /usr/local/python3.8.18/bin/pip3.8 /usr/bin/pip3

4.升级
pip3 install --upgrade pip文章来源地址https://www.toymoban.com/news/detail-776246.html

到了这里,关于python从就旧版本升级到3.8版本的文章就介绍完了。如果您还想了解更多内容,请在右上角搜索TOY模板网以前的文章或继续浏览下面的相关文章,希望大家以后多多支持TOY模板网!

本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如若转载,请注明出处: 如若内容造成侵权/违法违规/事实不符,请点击违法举报进行投诉反馈,一经查实,立即删除!

领支付宝红包 赞助服务器费用

相关文章

  • debian安装python的不同版本例如3.8

    要在 Debian 上安装 Python 3.8,可以按照以下步骤操作: 确保你的 Debian 系统已经更新到最新版本,可以使用以下命令更新: 安装 Python 3.8 的依赖项,以及构建 Python 时需要的工具和库: 下载 Python 3.8 的源代码包: 解压源代码包: 进入解压后的目录: 配置 Python 的编译选项:

    2024年02月09日
    浏览(11)
  • wsl2(debian)安装python的不同版本例如3.8

    要在Debian上安装 Python 3.8,可以按照以下步骤操作: 1.确保你的 Debian 系统已经更新到最新版本,可以使用以下命令更新: 2.安装 Python 3.8 的依赖项,以及构建 Python 时需要的工具和库: 3.下载 Python 3.8 的源代码包: 4.解压源代码包: 5.进入解压后的目录: 6.配置 Python 的编译

    2024年02月13日
    浏览(17)
  • Python 如何降低版本?从 Python3.9降低到 3.8, /anaconda/虚拟环境等.

    以 Win10 为例. 查看当前版本命令: 安装后查看一下版本是否降级成功. 打开 cmd 当然,前提是你的环境变量指向的是 anaconda 的路径. 如果长时间下载不成功,可能是镜像不在国内,可以更改为国内的清华镜像: Anaconda 的python 是被管理起来的,要降级很容易,但是自己安装的 python 就不容

    2024年02月08日
    浏览(18)
  • pycharm虚拟环境安装指定python版本/ python3.8 / 从python3.9降级到3.8

    我在网上找了一圈发现各种命令,尤其是说: virtualenv -p python3 py38 可以指定版本, 也没个解释,我真的酸Q ! 这个命令是意思是创建一个 py38 目录,实际上用的版本还是环境变量所指向的版本.-p 其实是指定路径比如, -p C:…python 要想指定版本,本机必须已经有一个版本,注意, 必

    2024年02月03日
    浏览(19)
  • Kafka版本滚动升级(不停机)

    升级Kafka集群的版本其实很简单,核心步骤只需要4步,但是我们需要在升级的过程中确保每一步操作都不会“打扰”到producer和consumer的正常运转。为此,笔者在本机搭了一个测试环境进行生产环境的版本升级测试。在开始之前,简要介绍一下测试环境的部署情况及目标:Ka

    2024年02月03日
    浏览(6)
  • GPT-4 VS GPT-3.5!你需要升级plus版本吗?

    GPT-4和 GPT-3.5语言模型在前沿技术的推动下,都具备了相当出色的自然语言生成能力。 鉴于GPT-4正式发布的消息已经引发了不小的关注,本文将从 完善度测试、推理能力测试、创造力测试 三个角度探讨两者的区别和优劣,为您提供实用的指导,帮助您了解是否需要升级plus版本

    2023年04月26日
    浏览(13)
  • kafka3.4.0版本升级--helm部署

    最近由于kafka的漏洞需要升级至3.4.0版本,之前由于不是helm部署,升级起来出现了权限问题、挂盘问题,在k8s搞了许久都搞不定,狠下心来,直接来一波helm安装,在2月份的时候,helm官网已推出chart-21.0.1包(https://artifacthub.io/packages/helm/bitnami/kafka)。用chart-21.0.1包准备开搞。

    2024年02月16日
    浏览(15)
  • Chrome 浏览器插件从 Manifest V2 升级到 V3 版本所需要修改的点

    Chrome 浏览器官方已经给出确定的时间来弃用 V2 版本的插件了。 最早从 2024 年 6 月 的 Chrome 127 开始,我们将开始停用 Chrome 的不稳定版本(开发者版、 Canary 版和 Beta 版)中的 Manifest V2 扩展程序。受此变化影响的用户会在浏览器中看到 Manifest V2 扩展程序自动停用,并且无法再

    2024年01月16日
    浏览(17)
  • rabbitmq卸载重新安装3.8版本

     卸载前先停止rabbitmq服务 查看rabbitmq安装的相关列表 卸载rabbitmq相关内容  查看erlang安装的相关列表   卸载erlang已安装的相关内容 删除有关的所有文件 通过cat /etc/redhat-release获取linux的版本 访问https://github.com/rabbitmq/rabbitmq-server/tags? 获取rabbitmq支持的linux版本 我选择这个版

    2024年02月11日
    浏览(15)
  • ubuntu升级Python版本

    一、已有Python版本 1.使用以下命令查找系统上所有安装的 Python 版本 2.使用以下命令更改 Python 3 的符号链接  3.使用以下命令检查 Python 3 符号链接的当前版本 二、下载所需版本 1. 使用以下命令安装软件包 2.添加 deadsnakes PPA 存储库,该存储库包含最新的 Python 版本 3.安装 Py

    2024年02月12日
    浏览(13)

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

博客赞助

微信扫一扫打赏

请作者喝杯咖啡吧~博客赞助

支付宝扫一扫领取红包,优惠每天领

二维码1

领取红包

二维码2

领红包