【报错记录】The project is using an incompatible version (AGP 8.3.0-alpha01) of the Android Gradle plugin.

这篇具有很好参考价值的文章主要介绍了【报错记录】The project is using an incompatible version (AGP 8.3.0-alpha01) of the Android Gradle plugin.。希望对大家有所帮助。如果存在错误或未考虑完全的地方,请大家不吝赐教,您也可以点击"举报违法"按钮提交疑问。

The project is using an incompatible version (AGP 8.3.0-alpha01) of the Android Gradle plugin. Latest supported version is AGP 8.1.3.

1. 背景

打开别人的kotlin项目,出现如上报错。简单查一下,错误说明本人电脑的Android Studio最高只支持到gradle 8.1.3,无法使用8.3.0。
the project is using an incompatible version (agp 8.3.0) of the android grad,Android 应用,android

the project is using an incompatible version (agp 8.3.0) of the android grad,Android 应用,android
the project is using an incompatible version (agp 8.3.0) of the android grad,Android 应用,android
升级Android Studio版本是不可能升级的,只能降gradle版本来寻求生成了。

2. 操作

2.1 降gradle版本

/gradle/wrapper/gradle-wrapper.properties,找一个可以运行成功的本地kotlin项目,复制过来。

distributionUrl=https\://services.gradle.org/distributions/gradle-8.0-bin.zip

the project is using an incompatible version (agp 8.3.0) of the android grad,Android 应用,android
TryAgain,继续报错:
Minimum supported Gradle version is 8.3-rc-2. Current version is 8.0.
the project is using an incompatible version (agp 8.3.0) of the android grad,Android 应用,android
简单查一下,错误说明,插件最低支持的gradle是8.3-rc-2,现在是8.0,那升级gradle是不可能升级的,只能降级插件版本。

2.2 降插件版本

项目下的build.gradle.kts。好像没看见版本号呀,这怎么降级?不慌,继续,刚刚那个可以运行成功的本地kotlin项目,复制过来。

    id("com.android.application") version "8.1.3" apply false
    id("org.jetbrains.kotlin.android") version "1.8.10" apply false

the project is using an incompatible version (agp 8.3.0) of the android grad,Android 应用,android
TryAgain,继续报错:
the project is using an incompatible version (agp 8.3.0) of the android grad,Android 应用,android

2.3 同步插件

app/build.gradle.kts,继续,刚刚那个可以运行成功的本地kotlin项目,复制过来。

    id("com.android.application")
    id("org.jetbrains.kotlin.android")

the project is using an incompatible version (agp 8.3.0) of the android grad,Android 应用,android

3. 结果

操作之后成功安装。

the project is using an incompatible version (agp 8.3.0) of the android grad,Android 应用,android文章来源地址https://www.toymoban.com/news/detail-843939.html

到了这里,关于【报错记录】The project is using an incompatible version (AGP 8.3.0-alpha01) of the Android Gradle plugin.的文章就介绍完了。如果您还想了解更多内容,请在右上角搜索TOY模板网以前的文章或继续浏览下面的相关文章,希望大家以后多多支持TOY模板网!

原文地址:https://blog.csdn.net/xunyan6234/article/details/136043903

本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如若转载,请注明出处: 如若内容造成侵权/违法违规/事实不符,请点击违法举报进行投诉反馈,一经查实,立即删除!

领支付宝红包 赞助服务器费用

相关文章

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

博客赞助

微信扫一扫打赏

请作者喝杯咖啡吧~博客赞助

支付宝扫一扫领取红包,优惠每天领

二维码1

领取红包

二维码2

领红包