神州数码命令:路由器配置

这篇具有很好参考价值的文章主要介绍了神州数码命令:路由器配置。希望对大家有所帮助。如果存在错误或未考虑完全的地方,请大家不吝赐教,您也可以点击"举报违法"按钮提交疑问。

路由器配置

一、路由器基本配置

1、进入特权模式:

Router>en

2、进入全局配置模式:

Router#config

3、定义路由器的名字为DCR :

Router(Config)#hostname DCR

4、特权用户的口令:

DCR (Config)#enable password 123456

5、启动远程服务功能:

DCR (Config)#telnet-server enable

6、配置远程用户的口令:

DCR (Config)#telnet admin password 7 admin

7、配置时钟频率:

Router(Config-Serial2/0)#physical-layer speed 64000
//将路由器上的 Serial 2/0 接口设置为以 64,000 kbps(即 64kbps)的速度进行数据传输。

8、配置用户登录路由器时认证:

aaa authentication login default local line enable

9、配置进入特权模式时认证:

aaa authentication enable default enable

10、配置路由器的用户名密码:

username admin password 0 admin000

11、配置进入特权模式密码:

enable password 0 admin000 level 15

二、静态路由配置

1、命令:ip route <目的IP> <子网掩码> {<接口名称>|<下一跳IP地址>} [<路由优先级>]
为路由优先级,取值范围为1~255,preference的值越小优先级越高。

Router(config)#ip route 1.1.1.0 255.255.255.0 2.1.1.1

2、默认路由
ip route 0.0.0.0 0.0.0.0{<接口名称>|<下一跳IP地址>} [<路由优先级>]

三、单臂路由

1、打开端口:
2、进入子接口配置IP地址,并封装dot1q协议到对应的VLAN。

Router_config#interface f0/0.1
Router(config_f0/0.1)#ip address 192.168.100.1 255.255.255.0
Router(config_f0/0.1)#encapsulation dot1Q 100 //封装dot1Q到VLAN 100
Route(config_f0/0.1)#exit
Router_config#interface f0/0.2
Router(config_f0/0.2)#ip address 192.168.200.1 255.255.255.0
Router(config_f0/0.2)#encapsulation dot1Q 200 //封装dot1Q到VLAN 200
Router(config_f0/0.2)#exit

四、动态路由协义配置

1、RIP协议

在DCR路由器上运行RIP路由协议的基本配置很简单,通常只需打开RIP开关、使能发送和接收RIP数据报,即按RIP缺省配置发送和接收RIP数据报(DCR路由器缺省发送RIP-II接收RIP-I和RIP-II)
(1)启动RIP协议:

Router(config)#router rip

(2)配置RIP协义版本:

Router(config-router-rip)#version 2

(3)配置接口使能发送/接收RIP数据报

Router(config-serial2/0)#ip rip work

(4)配置引入路由(缺省路由权值、配置RIP中引入其它协议的路由)
❶缺省路由权值:

Router(config-router-rip)#default-metric 3 //权值可设1-16

❷路由重分发:redistribute { static | ospf } [ metric ]
缺省情况下,路由器不引入其它路由。值指定以多大的路由权值引入路由,不指定则按缺省路由权值(default-metric)引入,取值范围1~16。

Router(config-router-rip)#redistribute ospf metric 5
//将OSPF路由以度量值5引入RIP

2、OSPF协议

(1)启动OSPF协议(必须)

Router(Config)#router ospf

(2)配置运行OSPF路由器的ID号(可选)
router id <router_id>
<router_id>为路由器ID号,以IP地址表示,点分十进制格式。缺省情况下,不配置路由器ID号,OSPF运行时从各接口的IP地址中选一个作为路由器ID号。

Router(config)#router id 1.1.1.1

(3)配置运行OSPF的网络范围(可选)
network <直连网络> <反掩码> area <区域号>

Router(Config-Router-Ospf)#network 10.0.0.0 0.0.0.255 area 1

(4)配置接口所属的域(必须)
ip ospf enable area <area_id>
要在某一个接口上运行OSPF协议,必须首先指定该接口属于一个区域。此命令用来在接口配置所属域。<area_id>为该接口所属区域的区域号。缺省情况下,接口不配置成属于某个区域。

Router(Config-Serial2/0)#ip ospf enable area 1

(5)配置OSPF引入路由参数
❶配置引入外部路由的缺省参数(缺省类型、缺省标记值、缺省代价值、缺省时间间隔和缺省数量上限)
缺省类型:default redistribute type { 1 | 2 }

Router(Config-Router-Ospf)# default redistribute type 1

缺省标记值:default redistribute tag //范围1~2147483647

Router(Config-Router-Ospf)# default redistribute tag 0x80000001

缺省代价值:default redistribute cost //范围1~65535

Router(Config-Router-Ospf)# default redistribute cost 10

缺省时间间隔:default redistribute interval //范围1~65535

Router(Config-Router-Ospf)# default redistribute interval 3

缺省数量上限:default redistribute limit //范围1~65535

Router(Config-Router-Ospf)# default redistribute limit 100

❷配置在OSPF中引入其它协议的路由(路由重分发)
redistribute ospfase { connected | static | rip } [ type { 1 | 2 } ] [ tag ] [ metric <cost_value> ]
connected表示引入直连路由作为外部路由信息,static表示引入静态路由作为外部路由信息,rip表示引入RIP协议发现路由作为外部路由信息;type指定路由的代价类型,1和2分别表示第一类外部路由和第二类外部路由;tag指定路由的标记,为路由的标记值,取值范围12147483648;metric指定路由的代价,<cost_value>为路由的代价值,取值范围116777215。缺省情况下,OSPF不引入外部路由。

Router(Config-Router-Ospf)#redistribute ospfase rip type 1 tag 3 metric 20

3、策略路由

❶ 新建源网络访问控制列表

Router(config)#ip access-list net1
Router(config)# permit 10.1.1.0 0.0.0.255

❷设置路由表

Router(config)#route-map pbr //建立路由表,名字为PBR
Router(config-route-map)#Match ip address net1 //配置匹配该路由表的网络
Router(config-route-map)#Match length 150 1500 //设置报文的长度范围
Router(config-route-map)#Set ip next-hop 192.168.50.1 //下一跳地址

❸应用到接口

Router(config)#int g0/4
Router(config)#ip policy route-map pbr

五、网络地址转换

设置指定接口作为网络地址转换的限定接口:ip nat {inside|outside}

Router#config
Router(config)#interface ethernet 0
Router(config-ethernet0)#ip nat inside

配置静态NAT/NAPT映射
NAT:ip nat inside source static <内部本地地址 > <内部全局地址>

Router(config)#ip nat inside static source 10.1.1.1 1.1.1.1

NAPT: Router(config)#ip nat inside source static tcp 192.168.1.7 1024 200.8.7.3 1024

Router(config)#ip nat inside source static udp 192.168.1.7 1024 200.8.7.3 1024

配置动态NAT/NAPT映射
(1)配置允许进行地址转换的内部私有地址;

Router(config)#access-list 1 permit 10.1.1.0 0.0.0.255

(2)配置动态NAT地址转换使用的外部公有地址的地址池;

Router(config)#ip nat pool pool-1 1.1.1.1 1.1.1.10 netmask 255.255.255.0

(3)建立内部私有地址与地址池或NAT外部接口的映射关系

Router(config)#ip nat inside source list 1 pool pool-1 overload

六、PPP协议配置

PPP(Point-to-Point Protocol)协议是为在点到点链路上传输数据包而设计的,它是在点到点链路上承载网络层数据包的一种链路层协议。PPP协议可以承载多种网络层协议数据包,如IP和IPX,并提供PAP、CHAP、MS-CHAP三种安全认证方式,以防止未经许可的非法用户访问。PPP支持串口同步和异步两种模式。PPP配置,需先在接口做好基础配置(接口IP,时钟频率等。)
1、PAP:验证方建立数据库,被验证方发送相同用户名密码。
(1)验证方:
建立用户名、密码:

Router(config)#user dcr password 0 aa

进入接口,封装PPP:

Router(config-serial2/0)#encapsulation ppp

选择验证方式PAP:

Router(config-serial2/0)#ppp authentication pap

(2)被验证方:
进入接口,封装PPP:

Router(config-serial2/0)#encapsulation ppp

发送对方的用户名密码:

Router(config-serial2/0)#ppp pap sent-username dcr password 0 aa

2、CHAP:发送的用户名必须是对方主机名,双方发送的密码要一致。
(1)验证方:
建立用户名、密码:

Router(config)#user RB password aa

进入接口,封装PPP:

Router(config-serial2/0)#encapsulation ppp

选择验证方式CHAP:

Router(config-serial2/0)#ppp authentication chap

(2)被验证方:
建立用户名密码:

Router(config)#user RA password aa

进入接口,封装PPP:

Router(config-serial2/0)#encapsulation ppp

注意:神州数码设备配置必须开启AAA本地认证。
Router(config)# aaa authentication ppp default local文章来源地址https://www.toymoban.com/news/detail-861507.html

到了这里,关于神州数码命令:路由器配置的文章就介绍完了。如果您还想了解更多内容,请在右上角搜索TOY模板网以前的文章或继续浏览下面的相关文章,希望大家以后多多支持TOY模板网!

本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如若转载,请注明出处: 如若内容造成侵权/违法违规/事实不符,请点击违法举报进行投诉反馈,一经查实,立即删除!

领支付宝红包 赞助服务器费用

相关文章

  • 神州数码-交换机基本配置

    一、端口安全设置命令: 查看端口信息:show interface ethernet 1/1 查看端口安全信息:show port-security interface ethernet 1/1 查看端口绑定的mac地址:show port-security address 二、初始化设置命令: ​恢复初始化设置:set default ​保存:write ​重启:reload telnet配置: ​创建用户:username 用

    2024年01月24日
    浏览(12)
  • 神州数码无线产品(AC+AP)配置

    注意: 本文主要掌握DCN自研无线产品的基本配置方法和注意事项,能够进行一般的项目实施、调试与运维 AP登录用户名和密码均为:admin AP默认IP地址为:192.168.1.10 AP默认情况下DHCP开启 AP静态地址配置: AP 开启/关闭DHCP功能: AP设置默认网关: 查看AP基本信息: AP注册管理

    2024年02月02日
    浏览(18)
  • 神州数码防火墙(DCN)NAT SSL-VPN配置

    SNAT,全称Source Network Address Translation,即源网络地址转换,是一种网络地址转换技术。其主要功能是将IP数据包的源地址转换成另外一个地址。在某些方案中,如虚拟机或计算实例需要与Internet建立出站连接时,可以使用SNAT。具体的操作过程是通过公共负载均衡器的前端IP为后

    2024年03月12日
    浏览(24)
  • DCN神州数码——设备基本指令 (超详细)

    打开交换机的SSH服务器功能 配置SSH客户端软件登录到交换机的用户名和密码 设置SSH认证超时时间 设置SSH认证重试次数 使能交换机作为SNMP代理服务器的功能 设置交换机的只读团体字符串 设置交换机的读写团体字符串 设置允许访问本交换机的NMS管理站的安全IP地址 要使用网

    2024年02月12日
    浏览(13)
  • NAT 地址转换路由器配置命令(华为路由器)

      #AR1路由器配置 # acl 2000    rule permit source any # interface GigabitEthernet0/0/1  nat outbound 2000  ip address 1.1.1.1 24 # interface GigabitEthernet0/0/0  ip address 172.16.1.1 255.255.255.0  # ip route-static 0.0.0.0 0.0.0.0 1.1.1.2 ip route-static 192.168.10.0 255.255.255.0 172.16.1.2 ip route-static 192.168.20.0 255.255.255.0 172.16.1.

    2024年02月17日
    浏览(15)
  • 路由器与静态路由配置命令(基础)

    目录 一、路由器的工作原理 二、路由器的基本配置 1、路由器配置模式 2、基本设置命令 3、接口IP地址配置 4、静态路由配置 三、路由器操作说明 1、登陆到路由器进入特权模式 2、指令基础 3、show指令介绍 4、CDP协议 5、指令基础 6、配置MOTD信息 7、配置信息的保存 8、端口配

    2024年02月07日
    浏览(17)
  • 路由器及其相关命令配置

    从源主机到目标主机的转发过程 路由器 :能够将数据包发到正确的目的地,并在转发过程中选择最佳路径的设备。 根据路由表转发数据 路由表 :路由器中维护的路由条目的集合,路由器根据路由表做路径选择。 路由表的形成: 对于路由表有两个重要的数据,就是 网段 和

    2024年02月03日
    浏览(13)
  • 路由器&交换机:配置命令

    ( 红色字体为重点命令) 第一节 用户模式 特权模式 全局模式 接口模式 命令 回车 Enable 简写 en Config terminal 简写 conf t Interface fastethernet0/1 简写 int f 端口号 交换机格式 Switch Switch# Switch(config)# Switch(config-if)# 路由器格式 Router Switch# Router(config)# Router(config-if)# 1. 非本层命令,要想

    2023年04月10日
    浏览(10)
  • 锐捷路由器配置命令完美宝典

    关于锐捷路由器配置命令,相信懂的人还不是很多,没有关系,下面就针对锐捷路由器,给大家详细的讲解一下,这些命令可能用的都不是很多,但是对于网络安全和性能来说很重要。 复制代码 代码如下: #Exit返回上一级操作模式 #del flash:config.text删除配置文件(交换机及170

    2024年02月07日
    浏览(14)
  • 华为路由器:RIP路由协议V2详细命令简单配置

    提示:文章写完后,目录可以自动生成,如何生成可参考右边的帮助文档 软件:eNSP 环境:Win 10 路由信息协议(RIP) 是一种距离矢量协议,这表示它根据跳数来判断到达目标的最佳路由,但16跳不可达,有一定的局限性。所以仅适用于小型网络。 网络拓扑以及IP地址规划如下:

    2024年02月04日
    浏览(18)

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

博客赞助

微信扫一扫打赏

请作者喝杯咖啡吧~博客赞助

支付宝扫一扫领取红包,优惠每天领

二维码1

领取红包

二维码2

领红包